Convert your E1/T1 PRI to Serial Interface

I was so worried once about the serial interfaces on my router, cuz I had only one serial ports on one of my routers among all, even for frame-relay I might have another router with multiple serial interfaces (!!) to make it frame-relay switch. So I decided first to use Ethernet network as workaround for the CCIE lab I am going to make ready. But I was wondering seeing on the IPExpert PG IOS configurations that the E1/T1 interfaces can be converted to serial interfaces and also I can use frame-relay there! And a router with multiple E1/T1 ports can be used as frame-relay switch! wow!! It was stunning to me I don’t know how you are considering it, I am just specifying the IOS commands to make it done:

At DTE side router 1:

controller T1 0/0/1
channel-group 0 timeslots 1-24

It will create a serial interface ‘Serial 0/0/1:0’ on the router immediately. I configured point-to-point frame-relay on the subinterface, so my commands are like:

interface Serial0/0/1:0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi

interface Serial0/0/1:0.1 point-to-point
ip address 10.10.111.1 255.255.255.0
ip ospf mtu-ignore
frame-relay interface-dlci 201

At DTE site router 2:

controller T1 0/0/0
channel-group 0 timeslots 1-24

interface Serial0/0/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
interface Serial0/0/0:0.1 point-to-point
ip address 10.10.111.2 255.255.255.0
ip ospf mtu-ignore
frame-relay interface-dlci 101

At DCE site router (frame-relay switch):

controller T1 0/1/0
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24

controller T1 0/0/0
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24

interface Serial0/0/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 101 interface Serial0/1/0:0 201

interface Serial0/1/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0/0:0 101

And that’s all! I was not needed the serial ports anymore, I just used my spare E1/T1 ports to convert those to serials and it worked like ‘wow’ 🙂

Advertisements

About Mijanur Rahman
Mijanur started blogging to save and share his study and research notes. A deep diver in technologies and loves to participate in technical brainstorming. Proud father of two wonderful daughters loves to spend time with them. He writes about the topics that people deal with every day mainly on technology arena. To get in touch contact him at bilashece@gmail.com

One Response to Convert your E1/T1 PRI to Serial Interface

  1. Daniel says:

    I had some issues with connecting my 3620s to my 7206VXR Frame Relay switch using T1 ports. i wasnt able to find any good documentation on configuring these, and your notes did the trick. i have to say that i can now study for my CCNP and CCIE with no issue.

    have a look at my unfinished lab. http://www.flickr.com/photos/daniel_messana/

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: