Automatic Call Recording at UCCX!!!

I was googling for such solution where call recording would start automatically without the recording key pressed by supervisors. Some renowned third party recording solutions are there like Verint or NICE, but I knew the recording feature is a built-in feature of UCCX, so why not using it? But the default option is to start recording by the supervisor himself manually for any selected agent, but it won’t start recording calls of all agents automatically. I started looking for it when found it can be done by modifying the workflow by someone from Cisco Support Community, and I just found it while navigating the Cisco Desktop Administrator (CDA) options. I have just paste down the screenshost from CDA, but the rest of integration and call flow scripting? You have to done it by yourself bro.

1. Navigate to Work Flow Groups>CAD Agent>Voice Contact Work Flows:

2. Add a new ‘Voice Contact Work Flow List’, I have named it ‘AutoCallRecord’:

3.  Add call record start event at ‘Answered Call’:

4. Similarly add another recording stop event:

5. Set a simple rule like ‘Called Party Number != empty’:

6. All done! This will start recording the agent calls automatically without any supervisor involvement, BUT these recorded calls would be available for the particular supervisor only, this is not global for all. That is, the CSQ agents calls would be available to only the supervisor assigned for those agents who can review/delete/save those. Now let’s look at the recorded files:

7.  And let’s see the supervisor recording access page:

One limitation is there for you, with Premium license you can record 80 simultaneous calls at max, and with Enhanced license it’s 32. Also, it’s resource hungry solution, so think before your server and sizing before configuring it! Also, you must have to configure SPAN based or Desktop sniffing based network configurations before you start recording/monitoring. This Cisco guide will must help you regarding all these:

http://72.163.4.161/en/US/products/sw/voicesw/ps556/products_tech_note09186a00801a62a8.shtml

Mobile Connect/Single Number Reach (SNR) on CUCM

I love this feature, if you don’t know what this is I’m giving a short description on it. If someone calls you on your deskphone and SNR is configured like your mobile phone is associated with your deskphone, your mobile phone will also be connected after configurable number of seconds. So when you are moving somewhere from your desk and, your call will never me missed 🙂

Now let’s talk about it’s configuration, it’s pretty easier to configure, follow me:

1. Create an end user and associate his deskphone at his profile:

2. Configure Remote Destination Profile (RDP):

3. Configure Remote Destination:

That’s all! Just create a route pattern to route your mobile call toward destination.

Now let’s have a try calling your deskphone, your mobile will also be connected after configured seconds (4 seconds by default), if you answer your call from the mobile your deskphone can sense it! wohoo!! your deskphone line will lid red as long as you are talking over mobile. 🙂 okey, now think you have reached near to your desk and now you want to keep talking using your deskphone, so hangup the call from the mobile it will get hold automatically and now resume it from your deskphone. It’s cool, right? I loved this feature so much! 🙂

Convert your E1/T1 PRI to Serial Interface

I was so worried once about the serial interfaces on my router, cuz I had only one serial ports on one of my routers among all, even for frame-relay I might have another router with multiple serial interfaces (!!) to make it frame-relay switch. So I decided first to use Ethernet network as workaround for the CCIE lab I am going to make ready. But I was wondering seeing on the IPExpert PG IOS configurations that the E1/T1 interfaces can be converted to serial interfaces and also I can use frame-relay there! And a router with multiple E1/T1 ports can be used as frame-relay switch! wow!! It was stunning to me I don’t know how you are considering it, I am just specifying the IOS commands to make it done:

At DTE side router 1:

controller T1 0/0/1
channel-group 0 timeslots 1-24

It will create a serial interface ‘Serial 0/0/1:0’ on the router immediately. I configured point-to-point frame-relay on the subinterface, so my commands are like:

interface Serial0/0/1:0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi

interface Serial0/0/1:0.1 point-to-point
ip address 10.10.111.1 255.255.255.0
ip ospf mtu-ignore
frame-relay interface-dlci 201

At DTE site router 2:

controller T1 0/0/0
channel-group 0 timeslots 1-24

interface Serial0/0/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
interface Serial0/0/0:0.1 point-to-point
ip address 10.10.111.2 255.255.255.0
ip ospf mtu-ignore
frame-relay interface-dlci 101

At DCE site router (frame-relay switch):

controller T1 0/1/0
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24

controller T1 0/0/0
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24

interface Serial0/0/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 101 interface Serial0/1/0:0 201

interface Serial0/1/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0/0:0 101

And that’s all! I was not needed the serial ports anymore, I just used my spare E1/T1 ports to convert those to serials and it worked like ‘wow’ 🙂

Bind Dynamips interface with Vmware OS NIC

That’s very important if you are practicing any topology where you need to communicate with VMware and dynamips. Specially I was needed this while I was trying to get IP from DHCP server running on dynamips router to a Windows running at VMware. That’s pretty cool, huh! I have pointed out the steps to get it done:

at WIndows Host Machine
————————
1. Create a Microsoft Loopback Adapter
2. Set the Loopback Adapter in DHCP mode

at Dynamips Router
——————
3. Bind the Loopback Adapter (NIO_gen_eth:) with one Dynamips NIC (for example FE0/0) at *.net file
4. Start the router
5. Configure a DHCP Pool (for example 192.168.1.0) at Dynamips router
6. Put a static IP (for example 192.168.1.1) of the Dynamips NIC (for example FE0/0) binded with that Loopback adapter
7. The Loopback adapter should get a DHCP IP from IOS DHCP Server

at VMware Workstation Global Configuation
—————————————–
8. go to Edit>’Virtual Network Settings’>’Host Virtual Network Mapping’
9. Click beside dropdown menu of VMnet2: (or whatever you like), here you will find the Loopback Adapter you created at step 1
10. Select the adapter, click at right ‘>’ key and add the proper subnet you created for DHCP
11. Click ‘Apply’ and ‘Ok’

at VMware Guest OS
——————
12. Select the Ethernet mode at ‘Custom:Specific virtual network’ and select the ‘VMnet2(Bridged)’ of the VM NIC you created at step 9
13. Set the guest NIC at DHCP mode and repair it, it should get the DHCP IP from Dynamips IOS DHCP.

I tested this on Windows XP, Windows 2003 Server Standard and Enterprise edition.

Who’s gonna love Virtualization?

Hi folks, the reason I’m posting such stupid long story I want to move your attention towards Virtualization for some minutes specially who are directly involved with designing and budgeting of IT infrastructures. It’s great if you have already idea and knowledge on it, if you don’t I shall request to kill some of your minutes please.

What is Virtualization?

The core concept of Virtualization is adapting multiple guest operating systems on a single hardware platform. These operating systems (either can be Windows or Unix or Mac, everything is supported now) will share the same hardware resources like CPU and Memory as you have allocated for each and they will use upto their limits. It’s the core concept of virtualization, but it’s technologies are growing day by day, now a days you can have redundancy of guests, moving one guest from one platform to another within seconds over Gigabit networks, virtual database clustering etc. etc. just what all we need at productions. Even the Bigs like Oracle, Sun, Microsoft, Cisco, Juniper all have already adapted their products for Virtualizations streamlines and also released their compatible products. Even processor manufacturers like Intel and AMD already released processors supporting Virtualizations.

So, why Virtualization?

Want to give you a simple example, it might be exactly like your production servers already running. Just point to your network monitoring system (NMS) and look for arbitrary four servers (like HP Proliant DL320) each with 1U rack space. What’s their CPU and Memory utilization? I guess the CPU is 10% during cold hours and fluctuating upto 50% at peak hours and the Memory is 30% at cold hours and 90% at peak hour. What about their storage utilization? Ok, let me guess they are using network storage systems. Now, if you tell me to design Virtualization systems at your data center I shall consider the parameters

1. Your rack U space (1U X4 = 4U in total)
2. Cooling power and operations (aKW X4 = 4aKW, a is considered as utilization per server)
3. Server power (bKW X4 = 4bKW, b is considered as utilization per server)
4. CPU utilization (10% to 50% fluctuating)
5. Memory utilization (30% to 90% fluctuating)

Now if I replace these 4 servers (HP DL320, 4GB RAM, dual core single Xeon processor) with 1 server (HP DL380,32GB RAM, quad core dual-Xeon processor), I can minimize the overall costing and improve overall performance as below:

1. Your rack U space (4U X1 = 4U in total)
2. Cooling power and operations (aKW X2 = 2aKW, a is considered as utilization per server)
3. Server power (bKW X2 = 2bKW, b is considered as utilization per server)
4. CPU utilization (50% to 90% fluctuating)
5. Memory utilization (30% to 90% fluctuating)

Thus it will save 50% of your power, will boost up you processes multiple times as you have plenty of RAM to utilize and dual processors, and the most important thing is saving your hardware cost upto 66%! And it’s not like dream, one of the Warid data center and contact center has moved to Virtualization and they have saved 80% overall! like a dream but it’s a true case story.

I don’t know if I have killed your time, but you might be the correct person if you have decision taking ability over IT infrastructure costing, even for such a place like Bangladesh where our primary concern is the expenditure for the IT services. You can hold down the costing or hardware, power systems, cooling systems and rack space also simultaneously improve the performance better than anytime you have. You can read the case studies how Virtualization is being implementing worldwide and laying off costs, lots are available on google, more specifically at vmware, cisco, microsoft and oracle sites.

Started blogging thru my Journey to CCIE Voice

This is my first blog thru my journey to CCIE Voice, I shall publish all new good findings/exclusive solutions/discussions/problems here to make it both documented and sharing with you guys.

I started from the very beginning while voice is getting known and surprising all that’s from 2007. I have completed my CCNA at the midst of 2007, started CCVP thereafter and completed CCVP certification at the end of 2008. I am an expert on UCCE/IPCC Enterprise indeed, that’s my first reading on voice technologies and even the CUCM, working with UCCE formore than three years, it was well known as IPCC Enterprise then, I started with ICM7.0, CVP3.1 and CCM4.2, that’s very old story! Will discuss with those later, and even I shall share all related UCCE also 🙂

Luckily I have a well sophisticated lab with me from this corporate with all routers/switches/MCS servers/IP Phones and what I need to start the CCIE lab practice, I had short of some equipments like PVDM, ESW, 28xx/3800 routers etc. and managed those with the help of my EDN friends, I am really grateful to them to lend me all those things for some months. I am also grateful to one of my best friends Chikkis (from india), I had those reading materials. software and even the most valuable part, inspirations, from him, and even now I’m member of some elite forums with his help, I’m really grateful to you buddy.

Well, no more discussion with inauguration, it’s time for lab and posting some important findings! Thanks is advance to you guys to visit my  wall regularly and put even silly comments over here, I shall not mind! 🙂